# File lib/typing.rb, line 256
                def check_xte_version
                        # Get the version string
                        version_string = `xte -h | head -n 1`

                        # Extract the version, convert to float
                        version = (version_string.match(/v([0-9].[0-9]+)/)).captures.first.to_f

                        if version < MIN_XTE_VERSION
                                STDERR.puts %(
                                        ##### WARNING #####
                                        Your version of xautomation (#{version}) is too old.  Please upgrade to at least #{MIN_XTE_VERSION} .
                                        This version is know to have problems with non-ASCII/non-US characters.
                                        ##### WARNING #####

                                ).gsub('    ', '')

                        end
                end